Tired of having creative flow cut off by CPU overload and latency issues

Hey guys,

I’ve been struggling lately on my machine to get uninterrupted work without having CPU overload every time I want to record a part which has already more than 5 tracks playing on. I’m not sure how I can fix this without upgrading my machine, which I cannot do at the moment, so I thought I’d ask this in our great community.
I’m working on a 2016 Macbook Pro, 8gb RAM. I’m mostly using as vsts Massive X, Serum, BBCSO, and some Spitfire and other plugins less frequently. I have some fx plugins from waves, which I believe can be CPU heavy. I’m running all my samples and instruments through a Seagate hard drive, and I have another one where I store all my projects and files.

My template is simple, just a standard routing from stacks to effects chain and print, some fx plugins already loaded but then I add my instruments as I go into a project.

My buffer size is already at the maximum, I try to save as much processing power as I can, but at some times it becomes impossible to work when it is crashing literally every time I press play.

Any ideas to improve this at all? What’s your tips? I was thinking to start switching my hard drive for ssd, do you think it would be better?

Thanks!

1 Like

An SSD would help with overall DAW performance and responsiveness etc but if your CPU is the bottleneck than that’s where the change needs to happen, especially if you’re at max buffer settings.

If upgrading isn’t an option then you’d be looking at workflow changes, freezing tracks, avoiding CPU heavy plugins, reducing voice counts etc.

I think freezing tracks is probably your best bet if your DAW supports it.

2 Likes

Starting with an SSD for some of your bigger VSTs like BBCSO would help, but if you’re only running 8gb of RAM, that’s too small for music production. 16gb at least, 32gb if you can do it. I also found in my experience that GarageBand/Logic tends to “overload” and run very inefficiently on MACs even though it’s their own program. I moved to PreSonus Studio One and rarely ever have issues unless I top out my RAM.

1 Like

If cpu is the issue it might help if you can render the parts you already have figured out to a wav file and use that on a separate audio track while muting those parts. I’m not familiar with mac stuff, but there should be an option in your daw that says something like “render/freeze” or “bounce to track” that’ll do that for you. You can always go back and change the parts later, but that way they’re not using up cpu resources while you figure out the new track.

2 Likes

I agree with @jpsheffer. Rendering some midi channels into audio can be a temporary fix.

1 Like

If you have a spare PC then buying Vienna Ensemble Pro would be a reasonable course of action. This allows you to use the RAM and disk space
by connecting them together by LAN. My own setup is a iMac 16 GB RAM where my DAW is kept with the processing power coming from my 64 GB ram 8 core processor allowing me to play a full orchestra without any problems leaving the iMac just on tick over.

1 Like

Thanks everyone for you answers. I try to render as much track as I can, but it does feel sometimes that Logic overload for no apparent reason. Might be just me, but I sometimes would just need to restart it to “reset” the CPU. Not sure if it is a thing.
I’ll have a look at Vienna Ensemble Pro. I have an old PC lying around, might be worth to use it back.

Hi Romain,

Have you tried this option of freezing your tracks if you use Logic - this has greatly helped me- brought to you by Mikael, worth watching if you want. Either way 8gb of ram not too much but this can help with what you have so far. Good luck.

1 Like

Also, try saving your project sessions mostly on your external hd if you don’t do that already, and backing them up on a 2nd external hd, saving them on your computer will slow processing time in general.

i had same problem on a pc. I can only guess that one of my 300 plugins was causing the problem. An os reinstall solved the problem. So it might have been something else, who knows, but that was the only way I was able to solve the issue. None of the other suggestions here worked.

Thanks a lot for all your suggestions. Unfortunately it has become even worst, if I have more than 10ish plugins on at the same time it starts crashing every 5-10 seconds. Freezing doesn’t seem to help in any way. Maybe as I am improving my production, my machine struggles to keep up. I’m thinking to either try VEP on a slave computer, or invest into a proper computer with 16 or 32 gb of RAM. Any recommendations? Thanks!

Ten plugins - but which ten? Let us know so we can help.

Though the RAM is a real issue on that MacBook. 8 is barely enough for anything.

TL;DR: Check CPU temperatures and disk health! I’m getting the impression that the machine is going unstable.

RAM should not really be an issue, unless we’re dealing with orchestral sample libraries - though 8 GB is really the pain threshold for basically using a computer at all these days, so you’ll have to close other applications. (Web browsers in particular! Those are the worst hogs known to mankind…)

Actual synths (like Serum) can consume substantial amounts of CPU time, and they’re generally single threaded, rendering number of CPUs/cores is irrelevant, except when running multiple instances of the synth.

Spitfire’s Kontakt libraries are also notorious for creating massive CPU load spikes when triggering notes, but other than that, they just leisurely stream samples, like any other library - though quite a few of them per note, especially if you use multiple microphones.

I’m not quite sure what the symptoms you’re describing add up to, I’d suggest checking CPU core temperatures, and CPU core clocks. If the CPU is overheating, it will thermothrottle, and since DAWs already hate SpeedStep (turbo clocks), you can imagine what this does - apart from just slowing down the CPU overall, obviously.

However, if freezing tracks does not help, I don’t think it has anything to do with RAM or CPU at all, but rather disk I/O. Basically any HDD should be fast enough for a few dozen tracks or so, but if the disk is starting to fail, it may gradually slow down (retries, moving data away from dying sectors etc), and it’s not unusual that the computer becomes near unusable for that reason alone, before you even see any actual data corruption. So, check the disk health!

1 Like

Thanks. I tend to use mostly BBCSO from Spitfire, Kontakt libraries from NI, Serum, Massive X, Reaktor…

Thank you so much, that’s really helpful. I’m really ignorant when it comes to computer tech, so I’ll do some research and check all this!

Reaktor, Serum and Massive are indeed very hungry plugs. Easy to drag a system down with those. Freeze them or record them whenever possible. Also, if the Kontakt stuff is using lots of scripting that can big you down as well. And if you are using larger pre-load sizes, you will use more memory. But the sizes you you use may be necessary in order for your system to work. If you can increase your disk buffer size, do that also.

I went back and re-read the thread and nobody has suggested increasing your disk buffer size, and that’s a big deal. If it’s sitting there at 128 then you may get this behavior. Try increasing it until the problem goes away. It may be that in order for your system to have low latency you will have to record or freeze your tracks quite a bit.

But also, if you keep this machine, bump your RAM up, without a doubt.