Logic won't open (BBCSO related)

Computer: Mac Pro 7,1 with 96GB Ram

Audio interface: Apogee Element 24 Thunderbolt


I was working on a track earlier, saved it and then quit

Just attempted to open Logic about 10 times and kept receiving an error (see attached screenshot)

I then shut down, waited a few minutes and booted up my machine again - kept receiving the same error message

Anyone have any insight into this?

Thank you

I then opened the Spitfire App and I attempted to repair three times, to no avail:

I tried repairing multiple times and eventually received this notification (which is perplexing as I never attempted to “Reset” it)

I’ve had problems with other plugins and the latest MacOS, which caused Logic to crash instantly on trying to access the plug in, but not with BBCSO. (Updating the other plugins to latest versions fixed the issues I was having).

I did update MMCSO recently - but hadn’t been having issues before.

My experience of Spitfire support was pretty good, so I would contact support and get their help.

1 Like

Thanks - yes I have contacted them by emailing customer support, posting a thread on their support page and DM’g them on IG and Twitter

I assume I will not hear from them until Monday since it is the weekend